Obtener Subclipse en Aptana para trabajar con la última versión de Subversion

votos
34

La versión de Subclipse (1.2.4) actualmente disponible a través del Administrador de complementos automático de Aptana no funciona con la versión más nueva de Subversion.

Veo en el sitio web de Subclipse, sin embargo, que tienen 1.4.2 para Eclipse. Así que agregué un nuevo sitio de actualización remota a mi administrador de actualizaciones. Cuando traté de instalarlo, me dijo que necesitaba Mylyn 3.0.0 . Así que después de mucha búsqueda encontré Mylyn 3.0.0 y agregué otro nuevo sitio de actualización remota a mi administrador de actualizaciones. Luego, cuando traté de instalar eso, me dijo que necesitaba org.eclipse.ui 3.3.0 o equivalente.

Mirando los detalles de configuración para Aptana, parece que está construido contra eclipse 3.2.2.

¿Alguien sabe si hay una manera de actualizar la versión de Eclipse Aptana que está construida contra 3.3.0? ¿O si hay alguna otra manera de hacer que Subclipse funcione con la última versión de Subversion?

Sé que esto no es necesariamente una pregunta de programación, pero espero que esté bien, ya que es muy relevante para la experiencia de programación.

Publicado el 01/08/2008 a las 14:56
fuente por usuario
En otros idiomas...                            


4 respuestas

votos
16

Subclipse no requiere Mylyn, pero el sitio de actualización incluye un complemento que integra Mylyn y Subclipse. Esto es para personas que usan Mylyn. En su caso, deseará simplemente anular la selección de Mylyn en el cuadro de diálogo de actualización.

Subclipse también requiere Subversion 1.5 y la versión correspondiente de las bibliotecas nativas JavaHL. He escrito el comienzo de una pregunta frecuente para ayudar a las personas a comprender JavaHL y cómo obtenerlo. Ver: http://desktop-eclipse.open.collab.net/wiki/JavaHL

Respondida el 15/09/2008 a las 14:26
fuente por usuario

votos
6

He tenido problemas con JavaHL en Eclipse Ganimedes, cuando funcionó bien en Eclipse Europa. No estoy seguro de cómo Aptana es diferente, pero intente actualizar JavaHL o cambiar a la implementación SVNKit pura-java dentro de la configuración de Subclipse.

Respondida el 01/08/2008 a las 15:41
fuente por usuario

votos
4

si no va a utilizar mylyn simplemente desmarque esa dependencia. No estoy muy familiarizado con Aptana, pero en Eclipse puedes ampliar lo que se está instalando y desmarcar cualquier cosa que no necesites.

Respondida el 29/08/2008 a las 00:47
fuente por usuario

votos
3

Usé la URL de actualización e instalé el adaptador JavaHL, el proyecto Subclipse y el adaptador SVNKit BETA.

Después de esto funcionó bien para mí, esto es para la plataforma Linux espero que funcione para usted.

Respondida el 26/08/2008 a las 14:41
fuente por usuario

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more