Aquí podría ser tu PUBLICIDAD


Sugerencias para escribir un plugin nsapi que llame a sybase, que tiene que ser seguro

votos
1

Me está costando mucho tratar de encontrar la documentación de Sybase que dice que si el cliente 12.5 es seguro para subprocesos. Necesito realizar llamadas a hilos seguras de sybase porque estoy escribiendo un plugin nsapi que vive en un entorno enhebrado. Entonces, o bien debo asegurarme de que el cliente de sybase pueda ejecutarse en un entorno enhebrado o necesitaría serializar las llamadas a sybase, lo que ralentizaría mi servidor web. Sugerencias?

Publicado el 12/03/2009 a las 17:18
fuente por usuario stu
En otros idiomas...        العربية       

1 respuestas

votos
0

El cliente abierto 12.5.1 es seguro para subprocesos, solo necesita enlazarse a la biblioteca correcta.

A partir de este lanzamiento, la versión segura para subprocesos de las bibliotecas Open Client / C se escribe usando hilos POSIX. Todas las bibliotecas multiproceso utilizan el patrón de nombres * _r.a para bibliotecas estáticas o * _r.so para bibliotecas compartidas. Para aplicaciones multiproceso, use bibliotecas con el sufijo "_r", como libcs_r.a. Para aplicaciones no multiproceso, use librerías sin el sufijo "_r", como libcs.a.

http://download.sybase.com/pdfdocs/sdr1251e/ocssun04.pdf

Respondida el 12/03/2009 a las 06:44
fuente por usuario Byron Whitlock


Aquí podría ser tu PUBLICIDAD