Pod anticuado failes causadas por Firebase / AdMob

votos
0

He intentado encontrar nuevas versiones de vaina-después del lanzamiento de Swift 4.2. Así que llamé

vaina obsoleta

en el terminal. De acuerdo con este este tipo de mensaje de error aparece:

Analyzing dependencies
[!] CocoaPods could not find compatible versions for pod Firebase/AdMob:
   In Podfile:
      Firebase/AdMob

Specs satisfying the `Firebase/AdMob` dependency were found, but they required a higher minimum deployment target.
CocoaPods could not find compatible versions for pod GoogleUtilities/MethodSwizzler:
In Podfile:
Firebase/AdMob was resolved to 5.8.0, which depends on
  Firebase/Core (= 5.8.0) was resolved to 5.8.0, which depends on
    FirebaseAnalytics (= 5.1.2) was resolved to 5.1.2, which depends on
      GoogleUtilities/MethodSwizzler (~> 5.2.0)

Specs satisfying the `GoogleUtilities/MethodSwizzler (~> 5.2.0)` dependency were found, but they required a higher minimum deployment target.

El destino de despliegue no fue cambiada y se encuentra todavía en 9.0. Estos firebase-pods se enumeran en mi PODFILE:

  pod 'Firebase/AdMob'
  pod 'Firebase/Messaging'
  pod 'Firebase/Core'

La versión actual de Firebase / AdMob es (5.8.0) .I ya retirado todas las vainas y los instaló nueva. Pero no trabajado.

Alguien ha una solución para esto?

Publicado el 19/09/2018 a las 17:10
fuente por usuario
En otros idiomas...                            


1 respuestas

votos
1

Hacer una pod update.

Esto se fijó hoy en Firebase 5.8.1. Los detalles en este tema GitHub .

Respondida el 20/09/2018 a las 02:14
fuente por usuario

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more